aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRodney Dawes <rodney.dawes@canonical.com>2017-02-02 17:13:07 -0500
committerRobert Tari <robert@tari.in>2021-07-09 01:30:37 +0200
commitbee22d6b1db9a479f81fad518eed9493759513c7 (patch)
tree50345b7ee868db39daa7e730cbd92d6a91eab2d2 /CMakeLists.txt
parent76789a3a3bd92c08e694b6d05020d20b49bff50f (diff)
downloadayatana-indicator-datetime-bee22d6b1db9a479f81fad518eed9493759513c7.tar.gz
ayatana-indicator-datetime-bee22d6b1db9a479f81fad518eed9493759513c7.tar.bz2
ayatana-indicator-datetime-bee22d6b1db9a479f81fad518eed9493759513c7.zip
Set the coverage test targeets from where the tests are added.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d346777..f80a129 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -117,8 +117,8 @@ if (${ENABLE_TESTS})
if (${ENABLE_COVERAGE})
find_package(CoverageReport)
ENABLE_COVERAGE_REPORT(
- TARGETS indicatordatetimeservice indicator-datetime-service
- TESTS test-actions test-alarm-queue test-clock test-datetime test-exporter test-formatter test-live-actions test-locations test-menu-appointments test-menus test-notification test-notification-response test-planner test-settings test-sound test-timezone-timedated test-utils test-eds-ics-all-day-events test-eds-ics-repeating-events test-eds-ics-nonrepeating-events test-eds-ics-repeating-valarms test-eds-ics-missing-trigger test-eds-ics-tzids test-eds-ics-tzids-2 test-eds-ics-tzids-utc test-eds-ics-non-attending-alarms test-eds-ics-repeating-events-with-individual-change manual-test-snap
+ TARGETS indicatordatetimeservice ayatana-indicator-datetime-service
+ TESTS ${COVERAGE_TEST_TARGETS}
FILTER /usr/include ${CMAKE_BINARY_DIR}/*
)
endif ()