aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-11-07 08:55:12 +0000
committerTarmac <Unknown>2012-11-07 08:55:12 +0000
commit2893be94b74895718d829b2f22388ea607de0980 (patch)
treed6a8e1a54f050aad7e2b97d9614b2252597a3179 /Makefile.am
parentd1bb8ca95f0f9d39c344fa41e297c73e88143800 (diff)
parent7ebd1bec24a732a0f7069e727ff4036f6b925e99 (diff)
downloadayatana-indicator-datetime-2893be94b74895718d829b2f22388ea607de0980.tar.gz
ayatana-indicator-datetime-2893be94b74895718d829b2f22388ea607de0980.tar.bz2
ayatana-indicator-datetime-2893be94b74895718d829b2f22388ea607de0980.zip
Add scaffolding for Google Tests. Fixes: https://bugs.launchpad.net/bugs/985060.
Approved by Lars Uebernickel, PS Jenkins bot.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 224ec45..c8b7f9a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,10 +1,12 @@
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-SUBDIRS = \
- src \
- data \
- tests \
- po
+SUBDIRS = po data src
+
+if BUILD_TESTS
+SUBDIRS += tests
+# build src first
+tests: src
+endif
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall