aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-02-17 15:59:12 -0600
committerTed Gould <ted@gould.cx>2012-02-17 15:59:12 -0600
commitf050e7bcb895159903d84b90d85f08901bfd3d46 (patch)
treebf23f7b1f4d852d78c7e477f18d78830f7ba9535 /configure.ac
parentb18a7b815228aa5fdbfee6272fdcc621becbf3b8 (diff)
parent4b4a2a0b444d26303df7865cebb56bf942c6d022 (diff)
downloadayatana-indicator-datetime-f050e7bcb895159903d84b90d85f08901bfd3d46.tar.gz
ayatana-indicator-datetime-f050e7bcb895159903d84b90d85f08901bfd3d46.tar.bz2
ayatana-indicator-datetime-f050e7bcb895159903d84b90d85f08901bfd3d46.zip
Adding in code coverage calculation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6931c2e..e548545 100644
--- a/configure.ac
+++ b/configure.ac
@@ -140,6 +140,16 @@ AM_CONDITIONAL(BUILD_CCPANEL, test x${have_ccpanel} = xyes)
GLIB_GSETTINGS
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Check to see if we're local
###########################
@@ -248,4 +258,5 @@ Date and Time Indicator Configuration:
Indicator Dir: $INDICATORDIR
CC Panel: $have_ccpanel
CC Panel Dir: $CCPANELDIR
+ gcov: $use_gcov
])