aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-11-07 08:55:12 +0000
committerTarmac <Unknown>2012-11-07 08:55:12 +0000
commit2893be94b74895718d829b2f22388ea607de0980 (patch)
treed6a8e1a54f050aad7e2b97d9614b2252597a3179 /tests/Makefile.am
parentd1bb8ca95f0f9d39c344fa41e297c73e88143800 (diff)
parent7ebd1bec24a732a0f7069e727ff4036f6b925e99 (diff)
downloadayatana-indicator-datetime-2893be94b74895718d829b2f22388ea607de0980.tar.gz
ayatana-indicator-datetime-2893be94b74895718d829b2f22388ea607de0980.tar.bz2
ayatana-indicator-datetime-2893be94b74895718d829b2f22388ea607de0980.zip
Add scaffolding for Google Tests. Fixes: https://bugs.launchpad.net/bugs/985060.
Approved by Lars Uebernickel, PS Jenkins bot.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e69de29..cc3b52a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -0,0 +1,52 @@
+TESTS =
+CLEANFILES =
+BUILT_SOURCES =
+check_PROGRAMS =
+
+###
+###
+###
+
+# stock UMB tests on user-visible strings
+include $(srcdir)/Makefile.am.strings
+
+check_LIBRARIES = libgtest.a
+nodist_libgtest_a_SOURCES = \
+ $(GTEST_SOURCE)/src/gtest-all.cc \
+ $(GTEST_SOURCE)/src/gtest_main.cc
+
+AM_CPPFLAGS = $(GTEST_CPPFLAGS) -I${top_srcdir}/src -Wall -Werror
+AM_CXXFLAGS = $(GTEST_CXXFLAGS)
+
+###
+###
+###
+
+TEST_LIBS = \
+ $(top_builddir)/src/.libs/libdatetime.so \
+ $(INDICATOR_LIBS) \
+ $(COVERAGE_LDFLAGS) \
+ libgtest.a
+
+TEST_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ $(INDICATOR_CFLAGS)
+
+BUILT_SOURCES += gschemas.compiled
+CLEANFILES += gschemas.compiled
+gschemas.compiled: Makefile
+ @glib-compile-schemas --targetdir=$(abs_builddir) $(top_builddir)/data
+
+###
+###
+###
+
+TESTS += test-indicator
+check_PROGRAMS += test-indicator
+test_indicator_SOURCES = test-indicator.cc
+test_indicator_LDADD = $(TEST_LIBS)
+test_indicator_CPPFLAGS = $(TEST_CPPFLAGS) -DSCHEMA_DIR="\"$(top_builddir)/tests/\""
+
+###
+###
+###