aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2023-01-12 00:08:42 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-02-04 23:43:05 +0100
commit0db5d4e7d671ff8af9b5905d111851e608c842c2 (patch)
tree4cecdde71ae52965941c90de10225964465169bd /src/CMakeLists.txt
parent2d4a7321471115bc04687296811687c8797a54b6 (diff)
downloadayatana-indicator-display-0db5d4e7d671ff8af9b5905d111851e608c842c2.tar.gz
ayatana-indicator-display-0db5d4e7d671ff8af9b5905d111851e608c842c2.tar.bz2
ayatana-indicator-display-0db5d4e7d671ff8af9b5905d111851e608c842c2.zip
Implement adaptive colour temperature profiles
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 33e42c3..d66cc1c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -21,6 +21,13 @@ if (ENABLE_LOMIRI_FEATURES)
)
endif ()
+if (ENABLE_COLOR_TEMP)
+ list (APPEND
+ SERVICE_LIB_SOURCES
+ solar.c
+ )
+endif ()
+
add_library (${SERVICE_LIB} STATIC ${SERVICE_LIB_SOURCES})
if (ENABLE_LOMIRI_FEATURES)