aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 13 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 9bd9847..4ff937e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,17 @@
#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
%:
- dh $@ --parallel --with translations
+ dh $@ --parallel
+get-orig-source:
+ uscan --noconf --force-download --rename --download-current-version --destdir=..