aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2013-08-13 09:11:46 -0400
committerMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2013-08-13 09:11:46 -0400
commit8109769399065b23a92a278c387b31a9c0455156 (patch)
tree2ec41c188c157dafaba91f4c6f440058ec4e8df5 /debian/rules
parentb95b1793605426da03ca61d3c825c93bd9eaf64e (diff)
parent624b11490965581fc1cc2eb21fdd7f74d065bd4d (diff)
downloadayatana-indicator-keyboard-8109769399065b23a92a278c387b31a9c0455156.tar.gz
ayatana-indicator-keyboard-8109769399065b23a92a278c387b31a9c0455156.tar.bz2
ayatana-indicator-keyboard-8109769399065b23a92a278c387b31a9c0455156.zip
Merge packaging
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 13 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index c816d1da..a69660c0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,21 @@
#!/usr/bin/make -f
# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+
%:
dh $@ --with autoreconf,translations
+
+override_dh_autoreconf:
+ NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+
+override_dh_install:
+ find debian/indicator-keyboard/usr/lib -name *.la -delete
+ find debian/indicator-keyboard/usr/lib -name *.a -delete
+ dh_install --fail-missing
+
+override_dh_auto_test:
+ dh_auto_test || ( cat tests/test-suite.log )