aboutsummaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2012-11-13 13:32:15 +0100
committerLars Uebernickel <lars.uebernickel@canonical.com>2012-11-13 13:32:15 +0100
commitef6b3b8daaef62a502c60e0faa22c3a4b10c0399 (patch)
treecccabb0cb11481dfee6fd292fe2e56c63c5d3140 /common/Makefile.am
parentb2c1e66e48d69199ba5d5cc607f47d695919a140 (diff)
downloadayatana-indicator-messages-ef6b3b8daaef62a502c60e0faa22c3a4b10c0399.tar.gz
ayatana-indicator-messages-ef6b3b8daaef62a502c60e0faa22c3a4b10c0399.tar.bz2
ayatana-indicator-messages-ef6b3b8daaef62a502c60e0faa22c3a4b10c0399.zip
Move service .xml into a common directory
Both the service (in src/) and the client library (in libmessaging-menu/) need access to the dbus interface description file. Until now, it resided in src, with both Makefiles calling gdbus-codegen on it. This patch moves the file to common/ and builds a convenience library that contains only the generated code.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
new file mode 100644
index 0000000..5bd7e20
--- /dev/null
+++ b/common/Makefile.am
@@ -0,0 +1,22 @@
+
+noinst_LTLIBRARIES = libmessaging-common.la
+
+indicator-messages-service.c: com.canonical.indicator.messages.service.xml
+ $(AM_V_GEN) gdbus-codegen \
+ --interface-prefix com.canonical.indicator.messages. \
+ --generate-c-code indicator-messages-service \
+ --c-namespace IndicatorMessages \
+ $^
+indicator-messages-service.h: indicator-messages-service.c
+
+BUILT_SOURCES = \
+ indicator-messages-service.c \
+ indicator-messages-service.h
+
+libmessaging_common_la_SOURCES = \
+ $(BUILT_SOURCES)
+
+libmessaging_common_la_CFLAGS = $(GIO_CFLAGS)
+libmessaging_common_la_LIBADD = $(GIO_LIBS)
+
+CLEANFILES = $(BUILT_SOURCES)