aboutsummaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
new file mode 100644
index 0000000..5bd7e20
--- /dev/null
+++ b/common/Makefile.am
@@ -0,0 +1,22 @@
+
+noinst_LTLIBRARIES = libmessaging-common.la
+
+indicator-messages-service.c: com.canonical.indicator.messages.service.xml
+ $(AM_V_GEN) gdbus-codegen \
+ --interface-prefix com.canonical.indicator.messages. \
+ --generate-c-code indicator-messages-service \
+ --c-namespace IndicatorMessages \
+ $^
+indicator-messages-service.h: indicator-messages-service.c
+
+BUILT_SOURCES = \
+ indicator-messages-service.c \
+ indicator-messages-service.h
+
+libmessaging_common_la_SOURCES = \
+ $(BUILT_SOURCES)
+
+libmessaging_common_la_CFLAGS = $(GIO_CFLAGS)
+libmessaging_common_la_LIBADD = $(GIO_LIBS)
+
+CLEANFILES = $(BUILT_SOURCES)