aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-09-09 09:18:53 -0500
committerTed Gould <ted@canonical.com>2009-09-09 09:18:53 -0500
commit5c8de01d9d2dd7167e51b60a8453737e3af49131 (patch)
treec376b6835b9e49aa647f6a91a8edc6f7736351b1 /configure.ac
parent81f620106e2776cc1cf54a3dbadd9575d21b6264 (diff)
downloadayatana-indicator-messages-5c8de01d9d2dd7167e51b60a8453737e3af49131.tar.gz
ayatana-indicator-messages-5c8de01d9d2dd7167e51b60a8453737e3af49131.tar.bz2
ayatana-indicator-messages-5c8de01d9d2dd7167e51b60a8453737e3af49131.zip
Adding in the local install flag to make that distcheck passes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b7db004..3cf72a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,17 +39,32 @@ AC_SUBST(APPLET_CFLAGS)
AC_SUBST(APPLET_LIBS)
###########################
+# Check to see if we're local
+###########################
+
+with_localinstall="no"
+AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall], [install all of the files localy instead of system directories (for distcheck)]), with_localinstall=$enableval, with_localinstall=no)
+
+###########################
# Indicator Info
###########################
-INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
+if test "x$with_localinstall" = "xyes"; then
+ INDICATORDIR="${libdir}/indicators/2/"
+else
+ INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
+fi
AC_SUBST(INDICATORDIR)
###########################
# DBus Service Info
###########################
-DBUSSERVICEDIR=`$PKG_CONFIG --variable=session_bus_services_dir dbus-1`
+if test "x$with_localinstall" = "xyes"; then
+ DBUSSERVICEDIR="${datadir}/dbus-1/services/"
+else
+ DBUSSERVICEDIR=`$PKG_CONFIG --variable=session_bus_services_dir dbus-1`
+fi
AC_SUBST(DBUSSERVICEDIR)
###########################