aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b7db004..3cf72a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,17 +39,32 @@ AC_SUBST(APPLET_CFLAGS)
AC_SUBST(APPLET_LIBS)
###########################
+# Check to see if we're local
+###########################
+
+with_localinstall="no"
+AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall], [install all of the files localy instead of system directories (for distcheck)]), with_localinstall=$enableval, with_localinstall=no)
+
+###########################
# Indicator Info
###########################
-INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
+if test "x$with_localinstall" = "xyes"; then
+ INDICATORDIR="${libdir}/indicators/2/"
+else
+ INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
+fi
AC_SUBST(INDICATORDIR)
###########################
# DBus Service Info
###########################
-DBUSSERVICEDIR=`$PKG_CONFIG --variable=session_bus_services_dir dbus-1`
+if test "x$with_localinstall" = "xyes"; then
+ DBUSSERVICEDIR="${datadir}/dbus-1/services/"
+else
+ DBUSSERVICEDIR=`$PKG_CONFIG --variable=session_bus_services_dir dbus-1`
+fi
AC_SUBST(DBUSSERVICEDIR)
###########################