aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-02-09 22:25:29 -0600
committerTed Gould <ted@gould.cx>2012-02-09 22:25:29 -0600
commit755287c475058aeef62273287113c1841f6111d9 (patch)
tree1f93c74dc2eeffce839b9e248de017bb39d2307a /configure.ac
parentff02cdb4a04ac01fde54f6c25247c0988d340444 (diff)
parent4f5f1e3ea9317f37e55028631f493f4a709cd8a5 (diff)
downloadayatana-indicator-messages-755287c475058aeef62273287113c1841f6111d9.tar.gz
ayatana-indicator-messages-755287c475058aeef62273287113c1841f6111d9.tar.bz2
ayatana-indicator-messages-755287c475058aeef62273287113c1841f6111d9.zip
Adding code coverage targets
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d6e7847..8b6f966 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,6 +91,16 @@ AC_SUBST(STATUS_PROVIDER_EMESENE_CFLAGS)
AC_SUBST(STATUS_PROVIDER_EMESENE_LIBS)
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Check to see if we're local
###########################
@@ -191,4 +201,5 @@ Messaging Indicator Configuration:
Prefix: $prefix
Indicator Dir: $INDICATORDIR
+ gcov: $use_gcov
])