aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 20:48:18 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 20:48:18 +0100
commit3e0b02e3e707da2f6749c5601d9130bd6d92760a (patch)
tree35c9aaec68f60766a2dd7b05dab9bc74c838339a /debian
parent7ed5f4ac35bae117a3665a9fc5223a3f3724f14e (diff)
downloadayatana-indicator-notifications-3e0b02e3e707da2f6749c5601d9130bd6d92760a.tar.gz
ayatana-indicator-notifications-3e0b02e3e707da2f6749c5601d9130bd6d92760a.tar.bz2
ayatana-indicator-notifications-3e0b02e3e707da2f6749c5601d9130bd6d92760a.zip
debian/{control,postinst}: Recompile GSettings schemas at post installation.
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rw-r--r--debian/postinst40
2 files changed, 41 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 7c64a79..e07594c 100644
--- a/debian/control
+++ b/debian/control
@@ -23,6 +23,7 @@ Package: ayatana-indicator-notifications
Architecture: any
Depends: ${shlibs:Depends},
${misc:Depends},
+ glib2.0-bin,
Description: Ayatana Indicator for viewing recent notifications
An Ayatana Indicator applet to display recent notifications sent to a
notification daemon such as notify-osd.
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..59b7114
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,40 @@
+#!/bin/sh
+# postinst script for ayatana-indicator-notifications
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <postinst> `abort-remove'
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ configure)
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0