aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-03-12 14:34:44 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-03-12 18:33:03 +0100
commit422443fc5c653bfd68aad90a2556a62f1edf1333 (patch)
tree72c941cdab3684b982da1b6e4053aaf0623a2821 /CMakeLists.txt
parent4d9589837e532df1015f7579439703c0af0164ca (diff)
downloadayatana-indicator-power-422443fc5c653bfd68aad90a2556a62f1edf1333.tar.gz
ayatana-indicator-power-422443fc5c653bfd68aad90a2556a62f1edf1333.tar.bz2
ayatana-indicator-power-422443fc5c653bfd68aad90a2556a62f1edf1333.zip
Make URL dispatcher build-dependency optional and handle battery settings request appropriately.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db80c6f..ac0cca6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,11 +41,17 @@ pkg_check_modules(SERVICE_DEPS REQUIRED
glib-2.0>=2.36
gio-2.0>=2.36
gio-unix-2.0>=2.36
- libnotify>=0.7.6
- url-dispatcher-1>=1)
+ libnotify>=0.7.6)
include_directories (SYSTEM ${SERVICE_DEPS_INCLUDE_DIRS})
+set(URL_DISPATCHER_1_REQUIRED_VERSION 1)
+pkg_check_modules(
+ URLDISPATCHER
+ url-dispatcher-1>=${URL_DISPATCHER_1_REQUIRED_VERSION}
+)
+include_directories(${URLDISPATCHER_INCLUDE_DIRS})
+
##
## custom targets
##