aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-12-15 14:44:40 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-12-15 14:44:40 +0100
commit809fa0a181017604afc9a66fd7880a0f683a5e50 (patch)
treeae0f03d5fcd5634fc54e2721e57aefc1c1135952 /CMakeLists.txt
parent01b36c885849a0af262a381469a394f4c9979cda (diff)
parent14726b036bd6d87a1aa601c6de34584ee8412788 (diff)
downloadayatana-indicator-power-809fa0a181017604afc9a66fd7880a0f683a5e50.tar.gz
ayatana-indicator-power-809fa0a181017604afc9a66fd7880a0f683a5e50.tar.bz2
ayatana-indicator-power-809fa0a181017604afc9a66fd7880a0f683a5e50.zip
Merge branch 'tari01-pr/detect-lomiri-schemas'
Attributes GH PR #53: https://github.com/AyatanaIndicators/ayatana-indicator-power/pull/53
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4937ae4..1de415a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,11 +68,10 @@ pkg_check_modules(SERVICE_DEPS REQUIRED
include_directories (SYSTEM ${SERVICE_DEPS_INCLUDE_DIRS})
-if(EXISTS "/usr/share/accountsservice/interfaces/com.lomiri.touch.AccountsService.Sound.xml")
- set (HAS_LOMIRI_ACCTSERVICE_SOUND ON)
- add_definitions ( -DHAS_LOMIRI_ACCTSERVICE_SOUND )
-else()
- set (HAS_LOMIRI_ACCTSERVICE_SOUND OFF)
+pkg_check_modules(LOMIRI_SCHEMAS lomiri-schemas)
+
+if(LOMIRI_SCHEMAS_FOUND)
+ add_definitions ( -DHAS_LOMIRI_SCHEMAS )
endif()
##