aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2022-02-23 02:28:41 +0100
committerRobert Tari <robert@tari.in>2022-02-23 02:57:55 +0100
commitcbf17a524ad51bef7fb034ca929f6f0da3fdb611 (patch)
tree1895752b1d11a92da673c1d5bd836622cee4c686 /CMakeLists.txt
parent8e990c91411ce1fe798eb16019e2543b40fc828b (diff)
downloadayatana-indicator-power-cbf17a524ad51bef7fb034ca929f6f0da3fdb611.tar.gz
ayatana-indicator-power-cbf17a524ad51bef7fb034ca929f6f0da3fdb611.tar.bz2
ayatana-indicator-power-cbf17a524ad51bef7fb034ca929f6f0da3fdb611.zip
Get Lomiri sounds path from lomiri-sounds pkg-config
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b8df4a8..a3eeb2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,8 +79,13 @@ if (ENABLE_LOMIRI_FEATURES)
APPEND
SERVICE_DEPS
lomiri-schemas
+ lomiri-sounds
+ )
+ pkg_get_variable(LOMIRI_SOUNDSDIR lomiri-sounds soundsdir)
+ add_definitions (
+ -DLOMIRI_FEATURES_ENABLED
+ -DLOMIRI_SOUNDSDIR="${LOMIRI_SOUNDSDIR}"
)
- add_definitions (-DLOMIRI_FEATURES_ENABLED)
endif ()
pkg_check_modules (SERVICE_DEPS REQUIRED ${SERVICE_DEPS})