aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2013-10-29 09:29:22 -0700
committerTed Gould <ted@gould.cx>2013-10-29 09:29:22 -0700
commit4913289a34ce6088ec06d7f32a55f0638e4c2da5 (patch)
tree2bd1cc2d0b1d2b226422ca3c8c2e5b474334abe9 /data/Makefile.am
parentfb134415e1e0042a00db4008e91adccd7d8eeff2 (diff)
downloadayatana-indicator-power-4913289a34ce6088ec06d7f32a55f0638e4c2da5.tar.gz
ayatana-indicator-power-4913289a34ce6088ec06d7f32a55f0638e4c2da5.tar.bz2
ayatana-indicator-power-4913289a34ce6088ec06d7f32a55f0638e4c2da5.zip
Add in the autostart config
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 9aed4e3..9a4caca 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -23,6 +23,19 @@ CLEANFILES += $(upstart_jobs_DATA)
EXTRA_DIST += $(upstart_jobs_in)
#
+# the xdg autostart job file
+#
+
+xdg_autostartdir = /etc/xdg/autostart
+xdg_autostart_DATA = indicator-power.desktop
+xdg_autostart_in = $(xdg_autostart_DATA:.desktop=.desktop.in)
+$(xdg_autostart_DATA): $(xdg_autostart_in)
+ $(AM_V_GEN) $(SED) -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+BUILT_SOURCES += $(xdg_autostart_DATA)
+CLEANFILES += $(xdg_autostart_DATA)
+EXTRA_DIST += $(xdg_autostart_in)
+
+#
# the gettings
#