aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 9aed4e3..9a4caca 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -23,6 +23,19 @@ CLEANFILES += $(upstart_jobs_DATA)
EXTRA_DIST += $(upstart_jobs_in)
#
+# the xdg autostart job file
+#
+
+xdg_autostartdir = /etc/xdg/autostart
+xdg_autostart_DATA = indicator-power.desktop
+xdg_autostart_in = $(xdg_autostart_DATA:.desktop=.desktop.in)
+$(xdg_autostart_DATA): $(xdg_autostart_in)
+ $(AM_V_GEN) $(SED) -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+BUILT_SOURCES += $(xdg_autostart_DATA)
+CLEANFILES += $(xdg_autostart_DATA)
+EXTRA_DIST += $(xdg_autostart_in)
+
+#
# the gettings
#