aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-09-21 23:59:48 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-09-21 23:59:48 +0200
commitce5fa07af99ac9d53e38213fd286fe8ac208e789 (patch)
tree1b203e7b677d78fabf431ce986cc09ff0b0ecd5c /CMakeLists.txt
parent4e646dac54541c70532374463767428e3f22cbd2 (diff)
parent0c689d5662beef6b90a0104ab3933058f23ce7f9 (diff)
downloadayatana-indicator-printers-ce5fa07af99ac9d53e38213fd286fe8ac208e789.tar.gz
ayatana-indicator-printers-ce5fa07af99ac9d53e38213fd286fe8ac208e789.tar.bz2
ayatana-indicator-printers-ce5fa07af99ac9d53e38213fd286fe8ac208e789.zip
Merge branch 'tari01-pr/indicator-ng'
Attributes GH PR #18: https://github.com/AyatanaIndicators/ayatana-indicator-printers/pull/18
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 24451e4..892b0e9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,7 +37,7 @@ endif ()
include (GNUInstallDirs)
find_package (PkgConfig REQUIRED)
include (FindPkgConfig)
-pkg_check_modules (SERVICE REQUIRED gtk+-3.0>=3.0 ayatana-indicator3-0.4>=0.2 dbusmenu-glib-0.4>=0.2 dbusmenu-gtk3-0.4)
+pkg_check_modules (SERVICE REQUIRED glib-2.0>=2.36 gio-2.0>=2.36 gio-unix-2.0>=2.36 libayatana-common)
find_program (CUPS_CONFIG cups-config REQUIRED)
execute_process (COMMAND ${CUPS_CONFIG} --cflags OUTPUT_VARIABLE CUPS_CFLAGS)
execute_process (COMMAND ${CUPS_CONFIG} --libs OUTPUT_VARIABLE CUPS_LIBS)
@@ -61,7 +61,7 @@ if (ENABLE_TESTS)
add_subdirectory (test)
if (ENABLE_COVERAGE)
find_package (CoverageReport)
- ENABLE_COVERAGE_REPORT (TARGETS "ayatana-printersmenu" "ayatana-indicator-printers-service" TESTS "mock-cups-notifier" FILTER /usr/include ${CMAKE_BINARY_DIR}/*)
+ ENABLE_COVERAGE_REPORT (TARGETS "ayatanaindicatorprintersservice" "ayatana-indicator-printers-service" TESTS "mock-cups-notifier" FILTER /usr/include ${CMAKE_BINARY_DIR}/*)
endif ()
endif ()