aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 75bb04b..08b87ea 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -2,6 +2,8 @@ BUILT_SOURCES=
CLEANFILES=
EXTRA_DIST=
+SUBDIRS = upstart
+
#
# the systemd unit file
#
@@ -38,5 +40,19 @@ BUILT_SOURCES += $(upstart_jobs_DATA)
CLEANFILES += $(upstart_jobs_DATA)
EXTRA_DIST += $(upstart_jobs_in)
+#
+# the xdg autostart job file
+#
+
+xdg_autostartdir = /etc/xdg/autostart
+xdg_autostart_DATA = indicator-printers.desktop
+xdg_autostart_in = $(xdg_autostart_DATA:.desktop=.desktop.in)
+$(xdg_autostart_DATA): $(xdg_autostart_in)
+ $(AM_V_GEN) $(SED) -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+BUILT_SOURCES += $(xdg_autostart_DATA)
+CLEANFILES += $(xdg_autostart_DATA)
+EXTRA_DIST += $(xdg_autostart_in)
+
DISTCLEANFILES = \
Makefile.in
+