aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarius Gripsgard <marius@ubports.com>2021-01-11 19:38:17 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-05-25 15:50:19 +0200
commitdc7faa221b5ffb8224b4dc1a3bc36610156745ba (patch)
tree13f4bcd8db100d9c92c58531bc7fd5ee50da0c17 /CMakeLists.txt
parent7803227f081df11869c218a732e24773052ca70f (diff)
downloadayatana-indicator-session-dc7faa221b5ffb8224b4dc1a3bc36610156745ba.tar.gz
ayatana-indicator-session-dc7faa221b5ffb8224b4dc1a3bc36610156745ba.tar.bz2
ayatana-indicator-session-dc7faa221b5ffb8224b4dc1a3bc36610156745ba.zip
Move common parts over to libayatana-common and clean up
This moves some common functions over to libayatana-common, this also removes the direct need for any ayatana indicators to depend on url-dispatcher as this will be handeled by libayatana-common. This also cleans up a pretty messy code and removes many duplicates.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3291aae..3d43114 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,13 +36,6 @@ pkg_check_modules (SERVICE REQUIRED
gio-unix-2.0>=2.36)
include_directories (${SERVICE_INCLUDE_DIRS})
-set(URL_DISPATCHER_REQUIRED_VERSION 0)
-pkg_check_modules(
- URLDISPATCHER
- lomiri-url-dispatcher>=${URL_DISPATCHER_REQUIRED_VERSION}
-)
-include_directories(${URLDISPATCHER_INCLUDE_DIRS})
-
set (CC_WARNING_ARGS " -Wall -pedantic -Wextra -Wno-missing-field-initializers")
set (ARCHIVE_NAME ${CMAKE_PROJECT_NAME}-${PROJECT_VERSION})