aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2011-08-24 22:03:53 +0100
committerConor Curran <conor.curran@canonical.com>2011-08-24 22:03:53 +0100
commite708841644c5be2997a4ff92cad8383a9260e7ed (patch)
tree1909bdd68f39bd2cc9a569420417b4a5d513476f /Makefile.am
parent4bb1329455828f51fb620a8d68c76e6c4273d080 (diff)
parenta73f98649bb15fb23d88adf1f178bcad63198057 (diff)
downloadayatana-indicator-session-e708841644c5be2997a4ff92cad8383a9260e7ed.tar.gz
ayatana-indicator-session-e708841644c5be2997a4ff92cad8383a9260e7ed.tar.bz2
ayatana-indicator-session-e708841644c5be2997a4ff92cad8383a9260e7ed.zip
merged teds string fixes and tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 28 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5850769..d63dac8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,8 +35,13 @@ dist-hook:
fi
TESTS = \
- test-ellipsis
+ test-ellipsis \
+ test-space-ellipsis \
+ test-ascii-quotes
+#####
+# Tests for there being proper ellipsis instead of three periods in a row
+#####
test-ellipsis: po
@echo "#!/bin/bash" > $@
@echo "(cd po && make $(GETTEXT_PACKAGE).pot)" >> $@
@@ -44,4 +49,26 @@ test-ellipsis: po
@echo "exit 0" >> $@
@chmod +x $@
+#####
+# Tests for there being a space before an ellipsis
+#####
+test-space-ellipsis: po
+ @echo "#!/bin/bash" > $@
+ @echo "(cd po && make $(GETTEXT_PACKAGE).pot)" >> $@
+ @echo "grep -c -e \"^msgid.* …\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"Space before ellipsis found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "exit 0" >> $@
+ @chmod +x $@
+
+#####
+# Tests for ASCII quote types
+#####
+test-ascii-quotes: po
+ @echo "#!/bin/bash" > $@
+ @echo "(cd po && make $(GETTEXT_PACKAGE).pot)" >> $@
+ @echo "grep -c -e \"^msgid \\\".*'.*\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"ASCII apostrophy found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "grep -c -e \"^msgid \\\".*\\\".*\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"ASCII quote found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "grep -c -e \"^msgid \\\".*\\\`.*\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"ASCII backtick found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "exit 0" >> $@
+ @chmod +x $@
+
CLEANFILES = $(TESTS)