aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRodney Dawes <rodney.dawes@canonical.com>2017-02-07 16:50:25 -0500
committerRodney Dawes <rodney.dawes@canonical.com>2017-02-07 16:50:25 -0500
commit47be95adcf9600979cbe0b3bb3269a6b9041efb2 (patch)
tree4ec70d28fa06f0435ecfd65d14d1badfb9b93ac9 /CMakeLists.txt
parent3e00c2f1483561613850820a674270c5d5154572 (diff)
downloadayatana-indicator-sound-47be95adcf9600979cbe0b3bb3269a6b9041efb2.tar.gz
ayatana-indicator-sound-47be95adcf9600979cbe0b3bb3269a6b9041efb2.tar.bz2
ayatana-indicator-sound-47be95adcf9600979cbe0b3bb3269a6b9041efb2.zip
Use coverage support from cmake-extras.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7d2624c..b8730fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,6 @@ add_definitions( -DGETTEXT_PACKAGE="${GETTEXT_PACKAGE}" )
find_package(PkgConfig REQUIRED)
include(GNUInstallDirs)
-include(Coverage)
include(UseVala)
# Workaround for libexecdir on debian
@@ -79,4 +78,9 @@ add_subdirectory(src)
enable_testing()
add_subdirectory(tests)
-
+find_package(CoverageReport)
+ENABLE_COVERAGE_REPORT(
+ TARGETS ${COVERAGE_TARGETS}
+ TESTS ${COVERAGE_TEST_TARGETS}
+ FILTER /usr/include ${CMAKE_BINARY_DIR}/*
+)