aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPete Woods <pete.woods@canonical.com>2013-08-19 18:01:44 +0100
committerPete Woods <pete.woods@canonical.com>2013-08-19 18:01:44 +0100
commit7e63d1c240a6b1e07275189d0af05edd1adbc654 (patch)
treeb9eb225618ee4be1adf81bbf65de091ce53d16d0 /CMakeLists.txt
parentbe867b88006520083a148785e8db761730b85eff (diff)
downloadayatana-indicator-sound-7e63d1c240a6b1e07275189d0af05edd1adbc654.tar.gz
ayatana-indicator-sound-7e63d1c240a6b1e07275189d0af05edd1adbc654.tar.bz2
ayatana-indicator-sound-7e63d1c240a6b1e07275189d0af05edd1adbc654.zip
Address review comments
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a1f1a1a..98dccef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,7 +39,6 @@ pkg_check_modules(
gio-2.0>=${GIO_2_0_REQUIRED_VERSION}
gio-unix-2.0
libxml-2.0
- gthread-2.0
)
include_directories(${SOUNDSERVICE_INCLUDE_DIRS})
@@ -53,6 +52,10 @@ include_directories(${SOURCE_BINARY_DIR})
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c11")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+add_definitions(
+ -Wall
+)
+
configure_file(
"config.h.in"
"${CMAKE_CURRENT_BINARY_DIR}/config.h"