aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a1f1a1a..98dccef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,7 +39,6 @@ pkg_check_modules(
gio-2.0>=${GIO_2_0_REQUIRED_VERSION}
gio-unix-2.0
libxml-2.0
- gthread-2.0
)
include_directories(${SOUNDSERVICE_INCLUDE_DIRS})
@@ -53,6 +52,10 @@ include_directories(${SOURCE_BINARY_DIR})
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c11")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+add_definitions(
+ -Wall
+)
+
configure_file(
"config.h.in"
"${CMAKE_CURRENT_BINARY_DIR}/config.h"