aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2015-01-27 11:42:26 -0600
committerTed Gould <ted@gould.cx>2015-01-27 11:42:26 -0600
commit26c4b845af442fd7968863929f4f62c8721fb687 (patch)
tree5b3ae042ea86f6d5e9d0fbd1e72ace0a7324b4b9 /tests/CMakeLists.txt
parentd788cd8f6910a8ff17454cc54175815a122f0c63 (diff)
downloadayatana-indicator-sound-26c4b845af442fd7968863929f4f62c8721fb687.tar.gz
ayatana-indicator-sound-26c4b845af442fd7968863929f4f62c8721fb687.tar.bz2
ayatana-indicator-sound-26c4b845af442fd7968863929f4f62c8721fb687.zip
Linking and starting and failing!
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt21
1 files changed, 16 insertions, 5 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 5c37ea3..a9ec204 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -92,11 +92,6 @@ add_library(
pa-mock.c
)
-target_link_libraries(
- pulse-mock
- ${SOUNDSERVICE_LIBRARIES}
-)
-
###########################
# Name Watch Test
###########################
@@ -131,6 +126,22 @@ add_test(accounts-service-user-test-player
)
###########################
+# Volume Control
+###########################
+
+include_directories(${CMAKE_SOURCE_DIR}/src)
+add_executable (volume-control-test volume-control-test.cc)
+target_link_libraries (
+ volume-control-test
+ indicator-sound-service-lib
+ pulse-mock
+ gtest
+ ${TEST_LIBRARIES}
+)
+
+add_test(volume-control-test volume-control-test)
+
+###########################
# Sound Menu
###########################