aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorRodney Dawes <rodney.dawes@canonical.com>2017-02-07 16:50:25 -0500
committerRodney Dawes <rodney.dawes@canonical.com>2017-02-07 16:50:25 -0500
commit47be95adcf9600979cbe0b3bb3269a6b9041efb2 (patch)
tree4ec70d28fa06f0435ecfd65d14d1badfb9b93ac9 /tests/CMakeLists.txt
parent3e00c2f1483561613850820a674270c5d5154572 (diff)
downloadayatana-indicator-sound-47be95adcf9600979cbe0b3bb3269a6b9041efb2.tar.gz
ayatana-indicator-sound-47be95adcf9600979cbe0b3bb3269a6b9041efb2.tar.bz2
ayatana-indicator-sound-47be95adcf9600979cbe0b3bb3269a6b9041efb2.zip
Use coverage support from cmake-extras.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 610ed9b..fb9d4b9 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -284,3 +284,17 @@ add_test(indcator-test
add_subdirectory(integration)
add_subdirectory(dbus-types)
add_subdirectory(service-mocks)
+
+# coverage reporting
+set(COVERAGE_TEST_TARGETS
+ ${COVERAGE_TEST_TARGETS}
+ name-watch-test
+ accounts-service-user-test
+ volume-control-test
+ sound-menu-test
+ notifications-test
+ media-player-user-test
+ greeter-list-test
+ indicator-test
+ PARENT_SCOPE
+)