aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 610ed9b..fb9d4b9 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -284,3 +284,17 @@ add_test(indcator-test
add_subdirectory(integration)
add_subdirectory(dbus-types)
add_subdirectory(service-mocks)
+
+# coverage reporting
+set(COVERAGE_TEST_TARGETS
+ ${COVERAGE_TEST_TARGETS}
+ name-watch-test
+ accounts-service-user-test
+ volume-control-test
+ sound-menu-test
+ notifications-test
+ media-player-user-test
+ greeter-list-test
+ indicator-test
+ PARENT_SCOPE
+)