aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2015-01-29 20:57:16 -0600
committerTed Gould <ted@gould.cx>2015-01-29 20:57:16 -0600
commite4ee5134da0cf9656db9ea201f2b7b53e92ac1b7 (patch)
tree0b90e4626df64466c55586931ae7cf05def4d087 /tests/CMakeLists.txt
parentaf63886e47b8262189d54712dbb34383ecf83669 (diff)
downloadayatana-indicator-sound-e4ee5134da0cf9656db9ea201f2b7b53e92ac1b7.tar.gz
ayatana-indicator-sound-e4ee5134da0cf9656db9ea201f2b7b53e92ac1b7.tar.bz2
ayatana-indicator-sound-e4ee5134da0cf9656db9ea201f2b7b53e92ac1b7.zip
Setup the PA mock as part of the indicator test
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index c1b4afc..d18e2dd 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -92,6 +92,8 @@ add_library(
pa-mock.cpp
)
+target_link_libraries (pulse-mock ${PULSEAUDIO_LIBRARIES})
+
###########################
# Name Watch Test
###########################
@@ -213,6 +215,7 @@ add_test(greeter-list-test-iterator
add_definitions(
-DINDICATOR_SOUND_SERVICE_BINARY="${CMAKE_BINARY_DIR}/src/indicator-sound-service"
+ -DPA_MOCK_LIB="${CMAKE_CURRENT_BINARY_DIR}/libpulse-mock.so"
)
add_executable (indicator-test indicator-test.cc)
target_link_libraries (