aboutsummaryrefslogtreecommitdiff
path: root/tests/integration/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-01-16 10:04:32 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-01-16 10:18:03 +0100
commitd2bcfdfe44568123b688c86b3a69e4a932641a33 (patch)
treea1941dee308054f8c0162fdec12a5b49d95d292a /tests/integration/CMakeLists.txt
parent507a4208b75e3eae389d7b33d31f48550b921579 (diff)
downloadayatana-indicator-sound-d2bcfdfe44568123b688c86b3a69e4a932641a33.tar.gz
ayatana-indicator-sound-d2bcfdfe44568123b688c86b3a69e4a932641a33.tar.bz2
ayatana-indicator-sound-d2bcfdfe44568123b688c86b3a69e4a932641a33.zip
tests/integration/utils/dbus-pulse-volume.cpp: Yet another location where we need to check for HAS_UT_ACCTSERVICE_SOUND_SETTINGS.
Diffstat (limited to 'tests/integration/CMakeLists.txt')
-rw-r--r--tests/integration/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/integration/CMakeLists.txt b/tests/integration/CMakeLists.txt
index a19c789..452006b 100644
--- a/tests/integration/CMakeLists.txt
+++ b/tests/integration/CMakeLists.txt
@@ -35,6 +35,10 @@ add_definitions(-DSOUND_SERVICE_BIN="${CMAKE_BINARY_DIR}/src/ayatana-indicator-s
-DFAKE_HOME="${FAKE_HOME}"
)
+if(EXISTS "/usr/share/accountsservice/interfaces/com.ubuntu.AccountsService.Sound.xml")
+ add_definitions(-DHAS_UT_ACCTSERVICE_SOUND_SETTINGS)
+endif()
+
set(GLIB_REQUIRED_VERSION 2.26)
pkg_check_modules(