aboutsummaryrefslogtreecommitdiff
path: root/tests/integration/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/integration/CMakeLists.txt')
-rw-r--r--tests/integration/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/integration/CMakeLists.txt b/tests/integration/CMakeLists.txt
index a19c789..452006b 100644
--- a/tests/integration/CMakeLists.txt
+++ b/tests/integration/CMakeLists.txt
@@ -35,6 +35,10 @@ add_definitions(-DSOUND_SERVICE_BIN="${CMAKE_BINARY_DIR}/src/ayatana-indicator-s
-DFAKE_HOME="${FAKE_HOME}"
)
+if(EXISTS "/usr/share/accountsservice/interfaces/com.ubuntu.AccountsService.Sound.xml")
+ add_definitions(-DHAS_UT_ACCTSERVICE_SOUND_SETTINGS)
+endif()
+
set(GLIB_REQUIRED_VERSION 2.26)
pkg_check_modules(