aboutsummaryrefslogtreecommitdiff
path: root/tests/service-mocks/accounts-mock/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-11-10 11:19:39 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-11-12 13:13:10 +0100
commit611fb696d239afec803bd2fdfdcbc1b475ff3a26 (patch)
treef7131a27f3a989d1294740466fed4f33af84cd6e /tests/service-mocks/accounts-mock/CMakeLists.txt
parent27963fd99ac38eee2477ec6ae6e8d2882959994a (diff)
downloadayatana-indicator-sound-611fb696d239afec803bd2fdfdcbc1b475ff3a26.tar.gz
ayatana-indicator-sound-611fb696d239afec803bd2fdfdcbc1b475ff3a26.tar.bz2
ayatana-indicator-sound-611fb696d239afec803bd2fdfdcbc1b475ff3a26.zip
Drop org.ayatana.AccountsService.Sound
Diffstat (limited to 'tests/service-mocks/accounts-mock/CMakeLists.txt')
-rw-r--r--tests/service-mocks/accounts-mock/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/tests/service-mocks/accounts-mock/CMakeLists.txt b/tests/service-mocks/accounts-mock/CMakeLists.txt
index 1549249..da9bc99 100644
--- a/tests/service-mocks/accounts-mock/CMakeLists.txt
+++ b/tests/service-mocks/accounts-mock/CMakeLists.txt
@@ -6,13 +6,7 @@ include_directories(${Qt5DBus_INCLUDE_DIRS}
"${CMAKE_SOURCE_DIR}/tests/service-mocks")
add_definitions(-DQT_NO_KEYWORDS=1)
-
-if(EXISTS "/usr/share/accountsservice/interfaces/com.lomiri.AccountsService.Sound.xml")
- add_definitions(-DHAS_LOMIRI_ACCTSERVICE_SOUND_SETTINGS)
- set(dbusinterface_sound_xml "com.lomiri.AccountsService.Sound.Mock.xml")
-else()
- set(dbusinterface_sound_xml "org.ayatana.AccountsService.Sound.Mock.xml")
-endif()
+set(dbusinterface_sound_xml "com.lomiri.AccountsService.Sound.Mock.xml")
set_source_files_properties(${dbusinterface_sound_xml} PROPERTIES
CLASSNAME AccountsServiceSoundMockInterface)