aboutsummaryrefslogtreecommitdiff
path: root/tests/service-mocks/accounts-mock/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/service-mocks/accounts-mock/CMakeLists.txt')
-rw-r--r--tests/service-mocks/accounts-mock/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/tests/service-mocks/accounts-mock/CMakeLists.txt b/tests/service-mocks/accounts-mock/CMakeLists.txt
index 1549249..da9bc99 100644
--- a/tests/service-mocks/accounts-mock/CMakeLists.txt
+++ b/tests/service-mocks/accounts-mock/CMakeLists.txt
@@ -6,13 +6,7 @@ include_directories(${Qt5DBus_INCLUDE_DIRS}
"${CMAKE_SOURCE_DIR}/tests/service-mocks")
add_definitions(-DQT_NO_KEYWORDS=1)
-
-if(EXISTS "/usr/share/accountsservice/interfaces/com.lomiri.AccountsService.Sound.xml")
- add_definitions(-DHAS_LOMIRI_ACCTSERVICE_SOUND_SETTINGS)
- set(dbusinterface_sound_xml "com.lomiri.AccountsService.Sound.Mock.xml")
-else()
- set(dbusinterface_sound_xml "org.ayatana.AccountsService.Sound.Mock.xml")
-endif()
+set(dbusinterface_sound_xml "com.lomiri.AccountsService.Sound.Mock.xml")
set_source_files_properties(${dbusinterface_sound_xml} PROPERTIES
CLASSNAME AccountsServiceSoundMockInterface)