aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2020-11-09 13:37:05 +0100
committerRobert Tari <robert@tari.in>2020-11-09 13:37:05 +0100
commita52a146f2749e8bd3a9b394dce55aebf64f3bff0 (patch)
tree9dc8befd9717766aedffbfd13874480142bb031b /setup.py
parent7146d97ec92696c72afe6c019765548644cb8a24 (diff)
downloadayatana-settings-a52a146f2749e8bd3a9b394dce55aebf64f3bff0.tar.gz
ayatana-settings-a52a146f2749e8bd3a9b394dce55aebf64f3bff0.tar.bz2
ayatana-settings-a52a146f2749e8bd3a9b394dce55aebf64f3bff0.zip
setup.py: Fix .dektop file generation
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ca1d8a3..cf826cd 100755
--- a/setup.py
+++ b/setup.py
@@ -11,6 +11,7 @@ iFile = open('data/applications/{}.desktop.in'.format(APPNAME), 'r')
oConfigParser = configparser.ConfigParser()
oConfigParser.optionxform = str
oConfigParser.read_file(iFile)
+iFile.close()
for strRoot, lstDirnames, lstFilenames in os.walk('po'):
@@ -36,7 +37,7 @@ for sSection in oConfigParser.sections():
oFile = open('data/applications/{}.desktop'.format(APPNAME), 'w')
oConfigParser.write(oFile, False)
-oFile.truncate
+oFile.close()
for strRoot, lstDirnames, lstFilenames in os.walk('po'):