aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-12-06 10:07:01 -0600
committerTed Gould <ted@gould.cx>2010-12-06 10:07:01 -0600
commitf590403207e1f675983c90188c1d8d24ebb1d0c1 (patch)
treefbbb2d25ad109926e396c7d4d11bb2ed9642c9d2 /src/Makefile.am
parent2209cb8604a929a6f1af5cec4991388ad32a7d1c (diff)
downloadlibayatana-appindicator-f590403207e1f675983c90188c1d8d24ebb1d0c1.tar.gz
libayatana-appindicator-f590403207e1f675983c90188c1d8d24ebb1d0c1.tar.bz2
libayatana-appindicator-f590403207e1f675983c90188c1d8d24ebb1d0c1.zip
Entirely unsure why this makes things better, but well, it does.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ce83951..673938b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -100,12 +100,20 @@ DBUS_SPECS = \
notification-watcher.xml
%.xml.h: %.xml
- echo "extern const char * $(subst -,_,$(subst .,_,$(basename $@)));" > $@
+ @echo "Building $@ from $<"
+ @echo "extern const char * $(subst -,_,$(subst .,_,$(basename $@)));" > $@
%.xml.c: %.xml
- echo "const char * $(subst -,_,$(subst .,_,$(basename $@))) = " > $@
- sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
- echo ";" >> $@
+ @echo "Building $@ from $<"
+ @echo "const char * $(subst -,_,$(subst .,_,$(basename $@))) = " > $@
+ @sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
+ @echo ";" >> $@
+
+BUILT_SOURCES += \
+ notification-item.xml.c \
+ notification-item.xml.h \
+ notification-watcher.xml.c \
+ notification-watcher.xml.h
CLEANFILES += \
$(DBUS_SPECS:.xml=.xml.h) \