aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-01-15 15:15:52 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-01-15 15:16:12 +0100
commitdc7ae44a907e6338e8bef28a2f35130ef6d09739 (patch)
tree87384b1f70fbadd032e6eae55f04c80a83d3108c /CMakeLists.txt
parent3cc2c952f3ec6d93649328a550f3ec5d10b238e2 (diff)
downloadlibayatana-common-dc7ae44a907e6338e8bef28a2f35130ef6d09739.tar.gz
libayatana-common-dc7ae44a907e6338e8bef28a2f35130ef6d09739.tar.bz2
libayatana-common-dc7ae44a907e6338e8bef28a2f35130ef6d09739.zip
Explicitly set ABI_VERSION / API_VERSION and use ABI_VERSION in the .so filename.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf34c7c..0a52550 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,9 @@ cmake_minimum_required (VERSION 2.8.9)
set(PROJECT_VERSION "0.8.1")
set(PACKAGE ${CMAKE_PROJECT_NAME})
+set(API_VERSION 0)
+set(ABI_VERSION 0)
+
# Options
option(DISABLE_TESTS "Disable tests" off)