aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-10-02 23:15:43 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-10-02 23:15:43 +0200
commit9bdaeabc50a0ea4568bc93bf9e790380813ab11a (patch)
treeed4e6048094317753e920dbe1f56822961cef082 /src/CMakeLists.txt
parent2097646924efa849076c0527f9a0dcf178504d22 (diff)
parent254ae9a5ef7d893f725456f5e25f9ec245acba5b (diff)
downloadlibayatana-common-9bdaeabc50a0ea4568bc93bf9e790380813ab11a.tar.gz
libayatana-common-9bdaeabc50a0ea4568bc93bf9e790380813ab11a.tar.bz2
libayatana-common-9bdaeabc50a0ea4568bc93bf9e790380813ab11a.zip
Merge branch 'tari01-pr/execute-command-warn'
Attributes GH PR #62: https://github.com/AyatanaIndicators/libayatana-common/pull/62
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ee44f7a..c7d351d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -7,6 +7,8 @@ target_link_libraries(ayatana-common
${DEPS_LIBRARIES}
)
+target_compile_definitions (ayatana-common PUBLIC GETTEXT_PACKAGE="${GETTEXT_PACKAGE}" LOCALEDIR="${CMAKE_INSTALL_FULL_LOCALEDIR}")
+
if(ENABLE_LOMIRI_FEATURES)
add_definitions( -DLOMIRI_FEATURES_ENABLED )
endif()