aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-04-20 15:39:42 -0500
committerTed Gould <ted@canonical.com>2009-04-20 15:39:42 -0500
commit6f87e9c09f9894db7fd6f42f65c8eb147c42a6e8 (patch)
treeb03356ce09b5d5cb1ac5b21b9aadfa1de586fddf /tests/Makefile.am
parentecad1e36dce18875461e76d2a47d8a0e11570ff6 (diff)
downloadlibayatana-indicator-6f87e9c09f9894db7fd6f42f65c8eb147c42a6e8.tar.gz
libayatana-indicator-6f87e9c09f9894db7fd6f42f65c8eb147c42a6e8.tar.bz2
libayatana-indicator-6f87e9c09f9894db7fd6f42f65c8eb147c42a6e8.zip
Adding a test to build a bunch of indicators
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am27
1 files changed, 26 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6117bee..7d72047 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,7 +2,8 @@
TESTS = \
test_simple \
test_interests \
- test_interests_multi
+ test_interests_multi \
+ test_thousand_indicators
libexec_PROGRAMS = \
test-interests-client \
@@ -12,6 +13,8 @@ libexec_PROGRAMS = \
test-interests-server3 \
test-interests-server4 \
test-interests-server5 \
+ test-thousand-indicators-client \
+ test-thousand-indicators-server
test-simple-client \
test-simple-server
@@ -114,3 +117,25 @@ test_interests_server5_LDADD = \
../libindicate/libindicate.la \
$(LIBINDICATE_LIBS)
+test_thousand_indicators: test-thousand-indicators-client test-thousand-indicators-server
+
+test_thousand_indicators_client_SOURCES = \
+ test-thousand-indicators-client.c
+
+test_thousand_indicators_client_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
+
+test_thousand_indicators_client_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+
+test_thousand_indicators_server_SOURCES = \
+ test-thousand-indicators-server.c
+
+test_thousand_indicators_server_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
+
+test_thousand_indicators_server_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+