aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-01-23 08:55:12 -0600
committerCharles Kerr <charles.kerr@canonical.com>2012-01-23 08:55:12 -0600
commit95daf102dac37a69686f8a86bf7fe47cd442c7d6 (patch)
tree3891a7075873c6eeb320fe0c8a572ca14655f5af /tests/Makefile.am
parent4f4190f71f8495e5bcf6779d73157931572e42ac (diff)
parent1cf6a9761db8beefc8d2a73c2cf9903264424c66 (diff)
downloadlibayatana-indicator-95daf102dac37a69686f8a86bf7fe47cd442c7d6.tar.gz
libayatana-indicator-95daf102dac37a69686f8a86bf7fe47cd442c7d6.tar.bz2
libayatana-indicator-95daf102dac37a69686f8a86bf7fe47cd442c7d6.zip
"bzr merge lp:indicator" + conflict resolution in tests suite
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am26
1 files changed, 24 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a70ee58..9319087 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -15,7 +15,8 @@ lib_LTLIBRARIES = \
libdummy-indicator-null.la \
libdummy-indicator-signaler.la \
libdummy-indicator-simple.la \
- libdummy-indicator-visible.la
+ libdummy-indicator-visible.la \
+ libdummy-indicator-entry-func.la
DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
XVFB_RUN=". $(srcdir)/run-xvfb.sh"
@@ -163,6 +164,27 @@ libdummy_indicator_simple_la_LDFLAGS = \
-avoid-version
#############################
+# Dummy Indicator Entry Func
+#############################
+
+libdummy_indicator_entry_func_la_SOURCES = \
+ dummy-indicator-entry-func.c \
+ dummy-indicator-entry-func.h
+
+libdummy_indicator_entry_func_la_CFLAGS = \
+ -Wall -Werror \
+ $(LIBINDICATOR_CFLAGS) -I$(top_srcdir)
+
+libdummy_indicator_entry_func_la_LIBADD = \
+ $(LIBINDICATOR_LIBS) \
+ -L$(top_builddir)/libindicator/.libs \
+ $(INDICATOR_LIB)
+
+libdummy_indicator_entry_func_la_LDFLAGS = \
+ -module \
+ -avoid-version
+
+#############################
# Dummy Indicator Visible
#############################
@@ -433,7 +455,7 @@ DISTCLEANFILES += service-manager-connect-nostart-tester
XML_REPORT = loader-check-results.xml
HTML_REPORT = loader-check-results.html
-loader-tester: test-loader libdummy-indicator-null.la libdummy-indicator-simple.la Makefile
+loader-tester: test-loader libdummy-indicator-null.la libdummy-indicator-simple.la libdummy-indicator-entry-func.la Makefile
@echo "#!/bin/bash" > loader-tester
@echo $(XVFB_RUN) >> $@
@echo gtester -k --verbose -o=$(XML_REPORT) ./test-loader >> loader-tester