aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index fc83186..bacdce6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,3 +1,5 @@
+TESTS =
+DISTCLEANFILES =
check_PROGRAMS = \
test-loader \
@@ -99,10 +101,13 @@ service_shutdown_timeout_LDADD = \
XML_REPORT = loader-check-results.xml
HTML_REPORT = loader-check-results.html
-loader-tester: test-loader libdummy-indicator-null.la libdummy-indicator-simple.la
- @gtester -k --verbose -o=$(XML_REPORT) ./test-loader
+loader-tester: test-loader libdummy-indicator-null.la libdummy-indicator-simple.la Makefile
+ @echo "#!/bin/sh" > loader-tester
+ @echo gtester -k --verbose -o=$(XML_REPORT) ./test-loader >> loader-tester
+ @chmod +x loader-tester
-check-local: loader-tester
+TESTS += loader-tester
+DISTCLEANFILES += loader-tester
-DISTCLEANFILES = $(XML_REPORT) $(HTML_REPORT)
+DISTCLEANFILES += $(XML_REPORT) $(HTML_REPORT)