aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-29 12:57:56 -0500
committerTed Gould <ted@canonical.com>2009-10-29 12:57:56 -0500
commita72fc583b5ae76ee0d4183ae72e4d905c0304bb7 (patch)
tree514c92ecb2e733ef89bf2150274fb8546a3325e2 /tests/Makefile.am
parentfc573dc11ca279d7a6aaf3c5164fb6e772f8d37c (diff)
downloadlibayatana-indicator-a72fc583b5ae76ee0d4183ae72e4d905c0304bb7.tar.gz
libayatana-indicator-a72fc583b5ae76ee0d4183ae72e4d905c0304bb7.tar.bz2
libayatana-indicator-a72fc583b5ae76ee0d4183ae72e4d905c0304bb7.zip
Making the gtester stuff into a autotest thingy.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index fc83186..bacdce6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,3 +1,5 @@
+TESTS =
+DISTCLEANFILES =
check_PROGRAMS = \
test-loader \
@@ -99,10 +101,13 @@ service_shutdown_timeout_LDADD = \
XML_REPORT = loader-check-results.xml
HTML_REPORT = loader-check-results.html
-loader-tester: test-loader libdummy-indicator-null.la libdummy-indicator-simple.la
- @gtester -k --verbose -o=$(XML_REPORT) ./test-loader
+loader-tester: test-loader libdummy-indicator-null.la libdummy-indicator-simple.la Makefile
+ @echo "#!/bin/sh" > loader-tester
+ @echo gtester -k --verbose -o=$(XML_REPORT) ./test-loader >> loader-tester
+ @chmod +x loader-tester
-check-local: loader-tester
+TESTS += loader-tester
+DISTCLEANFILES += loader-tester
-DISTCLEANFILES = $(XML_REPORT) $(HTML_REPORT)
+DISTCLEANFILES += $(XML_REPORT) $(HTML_REPORT)