aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDennis Schridde <devurandom@gmx.net>2011-09-19 23:43:26 -0500
committerTed Gould <ted@gould.cx>2011-09-19 23:43:26 -0500
commit4177700e45a02a7f35b32dc24dd7ec6e150d6a0a (patch)
tree08fe1f670ad1f93459773f61e3c0251a4d9116cc /configure.ac
parent21afbd946557e93304bdb34199d62594f365799f (diff)
downloadlibdbusmenu-4177700e45a02a7f35b32dc24dd7ec6e150d6a0a.tar.gz
libdbusmenu-4177700e45a02a7f35b32dc24dd7ec6e150d6a0a.tar.bz2
libdbusmenu-4177700e45a02a7f35b32dc24dd7ec6e150d6a0a.zip
Adding an optional build of the dumper
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e284980..f347625 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,8 +96,17 @@ AC_SUBST(DBUSMENUGTK_LIBS)
X11_REQUIRED_VERSION=1.3
+AC_ARG_ENABLE([dumper],
+ AC_HELP_STRING([--disable-dumper], [Disable dbusmenudumper tool]),
+ [enable_dumper=$enableval], [enable_dumper=auto])
+AM_CONDITIONAL([WANT_DBUSMENUDUMPER], [test "x$enable_dumper" != "xno"])
+
+AS_IF([test "x$enable_dumper" != "xno"],[
PKG_CHECK_MODULES(DBUSMENUDUMPER, gtk+-2.0 >= $GTK_REQUIRED_VERSION
- x11 >= $X11_REQUIRED_VERSION)
+ x11 >= $X11_REQUIRED_VERSION,
+ [have_dumper=yes]
+)
+])
AC_SUBST(DBUSMENUDUMPER_CFLAGS)
AC_SUBST(DBUSMENUDUMPER_LIBS)
@@ -243,3 +252,8 @@ AM_COND_IF([HAVE_VALA],
AC_MSG_NOTICE([ Vala bindings no])
)
+AS_IF([test "x$have_dumper" = "xyes"],
+ AC_MSG_NOTICE([ Dumper: yes]),
+ AC_MSG_NOTICE([ Dumper: no])
+)
+