aboutsummaryrefslogtreecommitdiff
path: root/libdbusmenu-glib/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-01-14 10:30:30 -0600
committerTed Gould <ted@gould.cx>2011-01-14 10:30:30 -0600
commitc6d2783146648f2c80635b693608fb20704b25bf (patch)
tree99e2144f18c57a784d8dde45d6324e3cebd7d3c2 /libdbusmenu-glib/Makefile.am
parent8545febdaac50ee3c741f20141c20c27911a5b96 (diff)
downloadlibdbusmenu-c6d2783146648f2c80635b693608fb20704b25bf.tar.gz
libdbusmenu-c6d2783146648f2c80635b693608fb20704b25bf.tar.bz2
libdbusmenu-c6d2783146648f2c80635b693608fb20704b25bf.zip
Adding the notdir on the build
Diffstat (limited to 'libdbusmenu-glib/Makefile.am')
-rw-r--r--libdbusmenu-glib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libdbusmenu-glib/Makefile.am b/libdbusmenu-glib/Makefile.am
index 4a65ac0..a1247a3 100644
--- a/libdbusmenu-glib/Makefile.am
+++ b/libdbusmenu-glib/Makefile.am
@@ -56,10 +56,10 @@ pkgconfig_DATA = dbusmenu-glib-0.4.pc
pkgconfigdir = $(libdir)/pkgconfig
%.xml.h: %.xml
- echo "extern const char * $(subst -,_,$(subst .,_,$(basename $@)));" > $@
+ echo "extern const char * $(subst -,_,$(subst .,_,$(basename $(notdir $@))));" > $@
%.xml.c: %.xml
- echo "const char * $(subst -,_,$(subst .,_,$(basename $@))) = " > $@
+ echo "const char * $(subst -,_,$(subst .,_,$(basename $(notdir $@)))) = " > $@
sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
echo ";" >> $@