aboutsummaryrefslogtreecommitdiff
path: root/libdbusmenu-glib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libdbusmenu-glib/Makefile.am')
-rw-r--r--libdbusmenu-glib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libdbusmenu-glib/Makefile.am b/libdbusmenu-glib/Makefile.am
index 4a65ac0..a1247a3 100644
--- a/libdbusmenu-glib/Makefile.am
+++ b/libdbusmenu-glib/Makefile.am
@@ -56,10 +56,10 @@ pkgconfig_DATA = dbusmenu-glib-0.4.pc
pkgconfigdir = $(libdir)/pkgconfig
%.xml.h: %.xml
- echo "extern const char * $(subst -,_,$(subst .,_,$(basename $@)));" > $@
+ echo "extern const char * $(subst -,_,$(subst .,_,$(basename $(notdir $@))));" > $@
%.xml.c: %.xml
- echo "const char * $(subst -,_,$(subst .,_,$(basename $@))) = " > $@
+ echo "const char * $(subst -,_,$(subst .,_,$(basename $(notdir $@)))) = " > $@
sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
echo ";" >> $@