aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-06-28 22:07:57 -0500
committerTed Gould <ted@gould.cx>2010-06-28 22:07:57 -0500
commit35589de9fe87c06f07772d9ffae74c2b8ca9141e (patch)
tree3cc768f4bcfdb0695e81347e6de82774f7fe5ab2 /tests/Makefile.am
parent8bfa911170eecf8b7c4dda05238777e1c066670f (diff)
downloadlibdbusmenu-35589de9fe87c06f07772d9ffae74c2b8ca9141e.tar.gz
libdbusmenu-35589de9fe87c06f07772d9ffae74c2b8ca9141e.tar.bz2
libdbusmenu-35589de9fe87c06f07772d9ffae74c2b8ca9141e.zip
Better name, distcheck fix, cleanup. Good stuff.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 31a8910..521cfbb 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,8 @@
DBUS_RUNNER=dbus-test-runner
+CLEANFILES=
+
TESTS = \
test-glib-objects-test \
test-glib-layout \
@@ -128,10 +130,12 @@ test_glib_layout_client_LDADD = \
test-json: test-json-client test-json-server Makefile.am
@echo "#!/bin/bash" > $@
@echo $(XVFB_RUN) >> $@
- @echo $(DBUS_RUNNER) --task ./test-json-client --task-name Client --parameter $(top_builddir)/tools/dbusmenu-dumper --parameter output.json --ignore-return --task ./test-json-server --task-name Server --parameter $(srcdir)/test-json-01.json --ignore-return >> $@
- @echo diff test-json-01.json output.json \> /dev/null >> $@
+ @echo $(DBUS_RUNNER) --task ./test-json-client --task-name Client --parameter $(top_builddir)/tools/dbusmenu-dumper --parameter test-json-01.output.json --ignore-return --task ./test-json-server --task-name Server --parameter $(srcdir)/test-json-01.json --ignore-return >> $@
+ @echo diff $(srcdir)/test-json-01.json test-json-01.output.json \> /dev/null >> $@
@chmod +x $@
+CLEANFILES += test-json-01.output.json
+
test_json_server_SOURCES = \
test-json-server.c
@@ -502,7 +506,7 @@ EXTRA_DIST = \
dbusmenu-gtk/mago_tests/data/test-gtk-label.json \
test-json-01.json
-CLEANFILES = \
+CLEANFILES += \
dbusmenu-gtk/mago_tests/dbusmenu.pyc
distclean-local: