aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-11-19 17:26:04 -0600
committerTed Gould <ted@canonical.com>2009-11-19 17:26:04 -0600
commit488550df2ebafd6e25b90b4818345fed1034395e (patch)
tree9490c8d83524f7f4c397a2c8444086c05d7052f6 /tests/Makefile.am
parentd8427db9d5559e49bbec99f0bd01aaeafa82b347 (diff)
downloadlibdbusmenu-488550df2ebafd6e25b90b4818345fed1034395e.tar.gz
libdbusmenu-488550df2ebafd6e25b90b4818345fed1034395e.tar.bz2
libdbusmenu-488550df2ebafd6e25b90b4818345fed1034395e.zip
Making the gtk tests use the Xvfb stuff
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8523b06..00f4e53 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -5,11 +5,9 @@ TESTS = \
test-glib-layout \
test-glib-properties \
test-glib-simple-items \
- test-mago
-
-GTK_TESTS = \
test-gtk-label \
- test-gtk-reorder
+ test-gtk-reorder \
+ test-mago
check_PROGRAMS = \
glib-server-nomenu \
@@ -127,6 +125,7 @@ test_glib_simple_items_LDADD = \
test-gtk-label: test-gtk-label-client test-gtk-label-server test-gtk-label.json Makefile.am
@echo "#!/bin/bash" > test-gtk-label
+ @echo $(XVFB_RUN) >> $@
@echo $(DBUS_RUNNER) --task ./test-gtk-label-client --task-name Client --task ./test-gtk-label-server --parameter $(srcdir)/test-gtk-label.json --task-name Server --ignore-return >> test-gtk-label
@chmod +x test-gtk-label
@@ -166,6 +165,7 @@ test_gtk_label_client_LDADD = \
test-gtk-reorder: test-gtk-label-client test-gtk-reorder-server Makefile.am
@echo "#!/bin/bash" > test-gtk-reorder
+ @echo $(XVFB_RUN) >> $@
@echo $(DBUS_RUNNER) --task ./test-gtk-label-client --task-name Client --task ./test-gtk-reorder-server --parameter $(srcdir)/test-gtk-label.json --task-name Server --ignore-return >> test-gtk-reorder
@chmod +x test-gtk-reorder