aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martin@piware.de>2011-02-21 11:30:50 +0100
committerMartin Pitt <martin@piware.de>2011-02-21 11:30:50 +0100
commit52e9e4c8125943abc8d7513501aad1698ab4d7f6 (patch)
tree96e92b55b8d315eac3aaa34aa10d6c3e58501044 /tests/Makefile.am
parent558fa9265c05452de03ddd9f8543dfdce1b81e7b (diff)
downloadlibdbusmenu-52e9e4c8125943abc8d7513501aad1698ab4d7f6.tar.gz
libdbusmenu-52e9e4c8125943abc8d7513501aad1698ab4d7f6.tar.bz2
libdbusmenu-52e9e4c8125943abc8d7513501aad1698ab4d7f6.zip
add test-glib-simple-items.py Python GI test
This replicates tests/test-glib-simple-items.c using Python and GI. Update the Makefile to use the locally generated GI typelibs for the tests.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 62142dc..9259ed1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -17,7 +17,8 @@ TESTS = \
test-gtk-shortcut \
test-gtk-reorder \
test-gtk-submenu \
- test-gtk-parser-test
+ test-gtk-parser-test \
+ test-glib-simple-items.py
check_PROGRAMS = \
glib-server-nomenu \
@@ -48,6 +49,9 @@ check_PROGRAMS = \
XVFB_RUN=". $(srcdir)/run-xvfb.sh"
+# for the GI tests, prefer/use the typelibs from the local build tree
+TESTS_ENVIRONMENT = env GI_TYPELIB_PATH=$(top_builddir)/libdbusmenu-glib:$(top_builddir)/libdbusmenu-gtk:$(GI_TYPELIB_PATH)
+
######################
# JSON Loader lib
######################
@@ -623,7 +627,7 @@ distclean-local:
-rm -rf $(builddir)/mago.results
DISTCLEANFILES = \
- $(TESTS) \
+ $(filter-out %.py, $(TESTS)) \
$(OBJECT_XML_REPORT) \
$(GTK_OBJECT_XML_REPORT)