aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 62142dc..9259ed1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -17,7 +17,8 @@ TESTS = \
test-gtk-shortcut \
test-gtk-reorder \
test-gtk-submenu \
- test-gtk-parser-test
+ test-gtk-parser-test \
+ test-glib-simple-items.py
check_PROGRAMS = \
glib-server-nomenu \
@@ -48,6 +49,9 @@ check_PROGRAMS = \
XVFB_RUN=". $(srcdir)/run-xvfb.sh"
+# for the GI tests, prefer/use the typelibs from the local build tree
+TESTS_ENVIRONMENT = env GI_TYPELIB_PATH=$(top_builddir)/libdbusmenu-glib:$(top_builddir)/libdbusmenu-gtk:$(GI_TYPELIB_PATH)
+
######################
# JSON Loader lib
######################
@@ -623,7 +627,7 @@ distclean-local:
-rm -rf $(builddir)/mago.results
DISTCLEANFILES = \
- $(TESTS) \
+ $(filter-out %.py, $(TESTS)) \
$(OBJECT_XML_REPORT) \
$(GTK_OBJECT_XML_REPORT)