aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-06-18 12:26:59 -0500
committerCharles Kerr <charles.kerr@canonical.com>2013-06-18 12:26:59 -0500
commit6c4e291f69fca1b30b08658fea9b7dd85d3a67ee (patch)
tree540714a9a579a01a7bcb5b6bf7be046d1bc3ef60 /tests/Makefile.am
parent9b75358ca14e1ad8a41c364195df748a1a1bbf5d (diff)
parentddbe5f1a0c8f487c1a633834b8f5df418162af92 (diff)
downloadlibdbusmenu-6c4e291f69fca1b30b08658fea9b7dd85d3a67ee.tar.gz
libdbusmenu-6c4e291f69fca1b30b08658fea9b7dd85d3a67ee.tar.bz2
libdbusmenu-6c4e291f69fca1b30b08658fea9b7dd85d3a67ee.zip
sync with trunk
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 356d803..b136935 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -36,6 +36,12 @@ TESTS += \
# test-gtk-submenu
endif
+if ENABLE_GTK_DOC
+TESTS += \
+ test_libdbusmenu_glib_gtkdoc \
+ test_libdbusmenu_gtk_gtkdoc
+endif
+
# The Python test only work on the system copy of
# dbusmenu, so while they can be usefule they're not
# good tests of what you're currently building. Handy
@@ -731,6 +737,18 @@ test-mago: test-gtk-label-client test-gtk-label-server $(srcdir)/dbusmenu-gtk/ma
# Other
#########################
+test_libdbusmenu_glib_gtkdoc:
+ @echo "#!/bin/bash" > $@
+ @echo cd $(abs_top_builddir)/docs/libdbusmenu-glib/reference >> $@
+ @echo gtester --verbose -k $(GTKDOC_CHECK) >> $@
+ @chmod +x $@
+
+test_libdbusmenu_gtk_gtkdoc:
+ @echo "#!/bin/bash" > $@
+ @echo cd $(abs_top_builddir)/docs/libdbusmenu-gtk/reference >> $@
+ @echo gtester --verbose -k $(GTKDOC_CHECK) >> $@
+ @chmod +x $@
+
examplesdir = $(docdir)/examples/
examples_DATA = \