aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martin@piware.de>2011-02-21 14:06:43 +0100
committerMartin Pitt <martin@piware.de>2011-02-21 14:06:43 +0100
commit83a270fd9db6cda2dbff19335c97361aa4ad6781 (patch)
tree5c730b3f984df880cc9fb84b2b0ee3df6cf8c683 /tests/Makefile.am
parentded5bb1e7c5bf42c24ed25a66c7e73ae8eaa54e0 (diff)
downloadlibdbusmenu-83a270fd9db6cda2dbff19335c97361aa4ad6781.tar.gz
libdbusmenu-83a270fd9db6cda2dbff19335c97361aa4ad6781.tar.bz2
libdbusmenu-83a270fd9db6cda2dbff19335c97361aa4ad6781.zip
add test-gtk-shortcut-client.py Python GI test
This replicates tests/test-gtk-shortcut-client.c using Python and GI.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c0081b0..f9102ed 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -16,6 +16,7 @@ TESTS = \
test-gtk-objects-test \
test-gtk-label \
test-gtk-shortcut \
+ test-gtk-shortcut-python \
test-gtk-reorder \
test-gtk-submenu \
test-gtk-parser-test \
@@ -476,6 +477,12 @@ test-gtk-shortcut: test-gtk-shortcut-client test-gtk-shortcut-server Makefile.am
@echo $(DBUS_RUNNER) --task ./test-gtk-shortcut-client --task-name Client --task ./test-gtk-shortcut-server --task-name Server --ignore-return >> $@
@chmod +x $@
+test-gtk-shortcut-python: test-gtk-shortcut-server Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo $(XVFB_RUN) >> $@
+ @echo $(DBUS_RUNNER) --task ./test-gtk-shortcut-client.py --task-name Client --task ./test-gtk-shortcut-server --task-name Server --ignore-return >> $@
+ @chmod +x $@
+
test_gtk_shortcut_server_SOURCES = \
test-gtk-shortcut-server.c